Ask Search:
Moshe BaitelmanMoshe Baitelman 

Old flow version throwing error?

We have had some trouble troubleshooting flow errors the past few days. At a basic level, it seems that old, inactive versions of active processes are still running and throwing errors.

For example, we have a process that updates related objects when a record is updated. There were two versions of this process. The first iteration of this process was titled "Update IA When Receipt Updates" and the second was changed to "Update IA When Shipment Status Updates".
There is only a single flow within this process. 

We got an error email with the subject: Error Occurred During Flow "Update_IA_When_Receipt_Updates" (the old name) even though that version is Inactive. (The error itself appears to be a valid error for the Active flow and is not the focus of my question.)

Has anyone come across anything like this before? I would be happy to provide more information if necessary, just not even sure where to start.

Any help or guidance would be greatly appreciated!
Best Answer chosen by Moshe Baitelman
Narender SinghNarender Singh
Maybe you only changed the label of the Process while cloning it and the API name remained same. 

All Answers

Narender SinghNarender Singh
Maybe you only changed the label of the Process while cloning it and the API name remained same. 
This was selected as the best answer
Moshe BaitelmanMoshe Baitelman
So that was my first thought but I checked and thought I had found two variations. I just checked again - you are correct, the API name was left the same. Thanks!