Ask Search:
Daphne ThompsonDaphne Thompson 

Package Not Found to complete Apex Specialist Superbadge

I'm trying to do Apex Specialist  challenge. As prerequisite an unmanaged package needs to be installed. But on clicking the link, the package is not available. Below is th screenshot. Error is - "Package Not FoundThe requested package doesn't yet exist or has been deleted. If this is a recently created package version, please try again in a few minutes or contact the package publisher." 
Could somebody please suggest me on how to go ahead with this challenge ?

Unmanaged package Link
Best Answer chosen by Daphne Thompson
Daphne ThompsonDaphne Thompson
Issue is Resolved !!!

All Answers

Tommaso BolisTommaso Bolis
I would try with a brand new trailhead playground.
Daphne ThompsonDaphne Thompson
Yes, I'm using the new trailhead playground but the package is not available in the source.
Tejesh VemulaTejesh Vemula
I am facing the same issue. I have created a brand new TP and used the browser in Incognoto mode.
Vikneash DevaVikneash Deva
I too am facing the same issue. Package not found. It was either moved or deleted. Submitted a case on that. Still no update.
Cezary MierzejewskiCezary Mierzejewski
Got the same issue, also submitted a case.
Remko BuijinkRemko Buijink
Got the same issue here! Will also submit a case. 
Tommaso BolisTommaso Bolis
Let us know if you get any answer from support.
Kacey BrownKacey Brown
Same problem...
Nagdeep KNagdeep K
Same problem
SRIKANTH HMSRIKANTH HM
Same problem 
Divya TodupunuriDivya Todupunuri
Same Problem..
Andrea PremariniAndrea Premarini
I have the same issue, and also for Aura Components Specialist :(
Chandana JChandana J
I am facing the same issue. Could someone help:-(
Asma Khabab KhanAsma Khabab Khan
i am facing the same issue...any response on whoever has submitted a case??
 
Krisjanis PunculisKrisjanis Punculis
Commenting for visibility - we have few new guys going through trailheads and one person was able to do this at 22. october, but other guys installing it yesterday (28. october) - encounters this issue (same with folloing trailhead instructions). So it got broken few days ago. We have opened the case to Salesforce but no response yet. So this is some gobal issue,
Nils BlumsNils Blums
Same here! Seems it was okay last week, as my colegue was able to instal it last tuesday, but when I was tryting yestrday, it doesn't work anymore.
Nils BlumsNils Blums
Same for "App Customization Specialist"
Asma Khabab KhanAsma Khabab Khan
same issue for Lightning experience specialist badge and App customization Specialist badge 
Tommaso BolisTommaso Bolis
Hi guys,
did you try in a developer org instead of using trailhead playground?
Nils BlumsNils Blums
Yes, we did! Same issue!
Waheed AnwarWaheed Anwar
I also have the same issue.
Luke OsmundsonLuke Osmundson
Same issue here as well, multiple environments tried.
SILVIO J OLIVEIRASILVIO J OLIVEIRA
My first superbadge :( Same issue!
Alessandro AscioneAlessandro Ascione
Same issue here, what should I do? 
Alex FerreiraAlex Ferreira
Same issue here!
Keith MurrayKeith Murray
Any updates?
Krisjanis PunculisKrisjanis Punculis

Hello,

We got answer from Trailhead support that this is a known technical issue and it is escalated to the technical team (no idea if there is any official post about this for everyone to see)

 

With further testing from our side we concluded that issue is with those Superbadges that ask for unmanaged package to be installed (for example Apex Specialist) will return error mentioned here, but if you choose some Superbadge were managed package is a prerequiste (like Security Specialist superbadge) - you can proceed with no problems. At least this helped for our new joiners to proceed with some Superbadges while we wait for fix to come through. So you can pick some other Superbadge to work on.

Nic E.Nic E.
I'm glad that SF knows about this.  Good to see another well monitored post by SF.
Pablo Gonzalez LinaresPablo Gonzalez Linares
Same issue!
Samuel MoysonSamuel Moyson

Same issue here

User-added image

Nitesh JNitesh J

@Nice E - how did you conclude that SF is well monitoring these posts? Most of us raised a case - including myself on Oct 30th 2019. The response was that they know about it but have no idea of ETA, etc.

Almost a week later .. no fix yet and quite disappointing response time from SF on such a critical issue to SF learning platform.

(I am being bocked from two superbadges as a result -> App Customization AND Aura components)

Edwin SchaefferEdwin Schaeffer
I'm noticing that I'm not getting this error on orgs that I've had open two months ago. However, I just spun off a new Trailhead playground about an hour ago, and I'm getting this error. Trailhead playgrounds are weird I've noticed where problems just "work themselves out" within a few hours. (Like, everything is not completely up yet.) Can some of the October people try again?
Jeff IsomJeff Isom
@Edwin, I just tried again and had the same issue. I originally ran into this issue on Friday, so the playground should have had plenty of time to get completely setup and issues worked out.
Luis CanoLuis Cano
Same issue, I followed each step and said the same 'Package not found'
Nitesh JNitesh J
@Edwin - you had me going :-(
I have several old playgrounds (3+ months old) - I tried but, as expected, not working -> If the managed package has been taken out of commission by SF there is no way it can be found regardless of how old or new the org is
Edwin SchaefferEdwin Schaeffer
@Nitesh - So here's what worked for me on the older org (From 9-01-19), and perhaps someone can find what the magic is.... The older Trailhead Playground org was used to do the Data Integration Specialist Superbadge.  ( https://trailhead.salesforce.com/en/content/learn/superbadges/superbadge_integration) It does mention on the SuperBadge that "if you're having trouble installing the package" to go here: https://trailhead.salesforce.com/help?article=Installing-a-package-or-app-to-complete-a-Trailhead-challenge and complete these steps.
  1. Open a new Incognito Window - Copy/Paste the unmanaged package link into the browser. I'm using this one from App Customization Specialist Superbadge: https://login.salesforce.com/packaging/installPackage.apexp?p0=04t0a000001wgua
  2. Select "Use Custom Domain" and paste your domain:  xxxxx-xxxxx-xxxxx-dev-ed.lightning.force.com
  3. Log in with that org's username and password (Reset your username password if you haven't done it yet)
  4. And it works:
Fig 2 is my User attributes. I'm using Trailhead Connected App v.15.0. I don't know why it's working in this org only, but if anyone else wants me to check something, let me know. 

Fig 1
User-added image


Fig 2

User-added image

 
Jeff IsomJeff Isom
@Edwin - That's so bizarre!   I just did my Integration Specialist badge on 10/22 and so I went to that playground and tried it there (just normally, not with the custom domain stuff.)  It worked like a charm. I'm a bit speechless... it doesn't make any sense.  But I guess I'll soldier on and hope my Data Integration badge work doesn't conflict with my Aura Specialist badge work.
Edwin SchaefferEdwin Schaeffer
Let me know if it works. I'll do the same. 
Linda BiLinda Bi
Working on my first Superbadge - Lightning Experience Specialist. 
It worked for me when I tried to install the package for the "Lightning App Builder" Module, but not the package of "LEX Superbadge". 
Waiting for the solution from Salesforce.
Ali BENAISSAAli BENAISSA
On your computer, open Chrome
At the top right, click More More and then New Incognito Window
login to your org
and past this URL :https://xxxxx.salesforce.com/packagingSetupUI/ipLanding.app?apvId=04tB0000000Q3Cq
Luke OsmundsonLuke Osmundson
@Ali Benaissa. That wasn't the issue. Regardless, the real issue has now apparently been solved, unmanaged packages are now once more accessible through Trailhead.
Nitesh JNitesh J
Yay - installation has been fixed by SFDC and all working now for App Customization superbadge. Happy days ..
Vikneash DevaVikneash Deva
Guys, the issue is fixed by the SFDC team and the unmanaged pack is good to install...!!!!!
Jose CunhaJose Cunha
There we go!!! :)
Daphne ThompsonDaphne Thompson
Issue is Resolved !!!
This was selected as the best answer
Ajeet SinghAjeet Singh
I am facing the same issue