Ask Search:
Deanna AaronDeanna Aaron 

Button not working: <span class="validStyle">No syntax errors in merge fields or functions.</span>

There's a button that stopped working. The "check syntax" originally returned with no issues.
Something changed since then. Now, it says: <span class="validStyle">No syntax errors in merge fields or functions.</span>

How do I resolve this? Thank you for your help.

FULL CODE:
https://composer.congamerge.com 
?sessionId={!API.Session_ID} 
&serverUrl={!API.Partner_Server_URL_290} 
&id={!Opportunity.Id} 

&reportid=[donation]00Oo0000004M2Dn 
&defaultpdf=1 
&ofn=Donation+for+{!Opportunity.Name}+{!TODAY()} 
&ac0=1 
&ac1=Donation+receipt+sent+{!Opportunity.Name}+{!TODAY()} 
&sc0=1 
&sc1=attachments 

&cetid=a2vo00000008ocl 
&_templateid=a34o0000006iDRX 
&templategroup=household
&cetg=household 
&emailsubject=Thank+You+for+your+Donation

&qvar0id=a2wo0000000PDDX?pv0={!Opportunity.AccountId} 
&emailtoid={qvar0}
Best Answer chosen by Deanna Aaron
Ahilesh RagavanAhilesh Ragavan
Looks like an error/issue on the custom message shown by Salesforce. May be the underlying HTML is exposed here.
Do the button functionality work still after save?

All Answers

Ahilesh RagavanAhilesh Ragavan
Looks like an error/issue on the custom message shown by Salesforce. May be the underlying HTML is exposed here.
Do the button functionality work still after save?
This was selected as the best answer
Deanna AaronDeanna Aaron
Thank you Ahilesh. Initially, the button functionality was able to work after saving-- even though it shows this syntax message. Something changed. In the end, I needed to delete the "space" after each line. This has been resolved.