Activity permissions - Answers - Salesforce Trailblazer Community
Ask Search:
Holly ThompsonHolly Thompson 

Activity permissions

I'm getting insufficient permissions for the component: 
Insufficient permissions for Activity component
I can't find any reason why. I thought it was because this can't live alongside Activity History related lists, but I made sure we weren't using those. Now I can't figure out how to display this.
Best Answer chosen by Jayson (salesforce.com) 
Meaghan HarraghyMeaghan Harraghy
Our user switched to Salesforce Classic and then back to Lightening and it worked. 

All Answers

sakshi nagpalsakshi nagpal
Hi Holly,
I am assuming your profile has access to event fields,record types
 Please refer links-:
https://help.salesforce.com/articleView?id=000188010&type=1&language=en_US
https://help.salesforce.com/articleView?id=000267721&language=en_US&type=1
Holly ThompsonHolly Thompson
Thank you, Sakshi for your answers. Unfortunately, these answers are related to related lists, not the lightning component. It is the lightning component that is showing the permissions issues. 
 
sakshi nagpalsakshi nagpal
This is a standard lightning component right?
Brian GannuscioBrian Gannuscio
Hi Holly, did you ever get this resolved?  I'm seeing the same thing in a sandbox environment and it isn't making sense.  I'm a system administrator so why don't I have permissions to see this component?
Holly ThompsonHolly Thompson
No, I never resolved it.  However, this was occurring in a sandbox we made for the client. Back in the main dev environment it works fine. We think we might be able to sort this out once Summer 19 is live.
 
Meaghan HarraghyMeaghan Harraghy
Has this been resolved? This is happening with one user in Production but their SandBox is fine. 
Meaghan HarraghyMeaghan Harraghy
Our user switched to Salesforce Classic and then back to Lightening and it worked. 
This was selected as the best answer
Holly ThompsonHolly Thompson
Interesting Meaghan! I'll have to try this.
 
Sabeen KhanSabeen Khan
Just in case anyone else is having the same problem I spent most of the say trying to resolve this issue and then came across this post which solved the problem for me: https://success.salesforce.com/answers?id=9063A000000la6xQAA

Basically under Record Page Settings in Setup, the Activity Timeline View needs to be selected!
Hanna DekkerHanna Dekker
I spent all day trying to solve this as well ( I think it was caused by my recent Linkedin Navigatior installation?).  Thanks so much for saving me from 5 more hours of guessing. 
Amy OplingerAmy Oplinger
Another place to check is the users own Record Page Settings...they must have Activity Timeline selected as their default.