Ask Search:
Christine MarshallChristine Marshall 

Cannot Link Trailhead Badges With Success/Trailblazer Community Profile

I do know how to link my Trailhead account with my success community profile!

BUT my Trailhead account is already linked to a previous community profile I had via a job. I now use my personal profile and would like to link it to Trailhead to display my badges. I know you cannot link your Trailhead to 2 community profiles but I do not have access to the old account to remove the link...

I have contacted Salesforce but they won't help me and keep telling me to post in the community/developer community. Does anyone have contact details for someone at Salesforce who can remove the Trailhead link on my old profile so I can re-link to my new profile?

Thanks! 
Best Answer chosen by Christine Marshall
Chris EmmettChris Emmett

Here are ALL the details I provided. Hope it get's you further :-)

Problem Type: General Salesforce Functionality
Product Topics: All Help or Online Training Questions
Case Subject: Linking Trailhead/Webassessor to Success Community
Severity Level: Level 4 - Medium
Instance Type: Production
Have you granted login access?: No
Steps to Reproduce: Click Connect Certification Account in the Success Community profile.

All Answers

Steve BainesSteve Baines
  1. Login to trailhead with community credentials
  2. Go to trailhead profile settings
  3. Connect trailhead account to facebook or linked in
  4. Log out of trailhead
  5. Log in to trailhead with facebook or linked in
  6. Go to trailhead profile settings
  7. Disconnect Salesforce credentials from user account
  8. Connect trailhead to your new salesforce/community credentials
Christine MarshallChristine Marshall
Hi Steve,

I've followed your steps but I'm a bit confused about "Disconnect Salesforce credentials from user account". The only Salesforce login details I see are my presonal credentials. I don't see my old work details so I'm not sure what I should be disconnecting? 

Thanks, Christine 
Chris EmmettChris Emmett
As mentioned on your other thread, I managed to get my account unlinked via a support ticket. It's strange how you've not had any luck via that avenue. If it helps, this is the original text I used ot raise my case:
 
Hi,

I'm unable to link my Trailhead or Webassessor to the success community. Every time I try, I get an error saying:

Please correct the following error(s):
We couldn't verify your email.

I suspect this is because they are linked to another account, however, I can't currently access that account as it seems to have been deactivated/expired.

Can you please help?

 

The case got escalated a few times but it was eventually fixed in about a week.
Christine MarshallChristine Marshall
Thanks Chris - do you remember what Topic/Category you chose for the support ticket?
Chris EmmettChris Emmett

Here are ALL the details I provided. Hope it get's you further :-)

Problem Type: General Salesforce Functionality
Product Topics: All Help or Online Training Questions
Case Subject: Linking Trailhead/Webassessor to Success Community
Severity Level: Level 4 - Medium
Instance Type: Production
Have you granted login access?: No
Steps to Reproduce: Click Connect Certification Account in the Success Community profile.

This was selected as the best answer
Natalya MurphyNatalya Murphy
If you're getting this error message, it usually means you've enabled the Trailhead link in another community, such as success.salesforce.com or partners.salesforce.com.   You need to first unlink Trailhead from there and then link it here.   

So log in to the community where you currently have Trailhead linked, go to your profile just like you do in this community, and then do BOTH of the following:
  • Uncheck the checkbox for sharing your Trailhead information
  • Delete your associated email address by clicking the X next to your email address
You must do BOTH of the above or it won't work.
Christine MarshallChristine Marshall
Natalya,

If you read my original question you can see I knew my Trailhead was linked to another account. My issue was I no longer had access to that account to unlink it.
Debjyoti ChakrabortyDebjyoti Chakraborty
Hi Christine,

I have a similar problem with my Trailhead. Will you mind explaining the solution to this?

Thanks,
Deb
Christine MarshallChristine Marshall
Hi Debjyoti,

Do you have access to the other Salesforce community account your Trailhead is linked to?

This issue tends to occur when you have multiple community profiles. I had linked my Trailhead with an old work profile that I no longer had access to.

If I had access I could have logged in and disconnected the link, which would then allow me to link it to my new account.

Christine 
Troy CenterTroy Center
I just got off the phone with Salesforce. They escalated my case to Engineering. This is clearly a problem and I'm NOT making any mistakes. I'll post an update when I get one. 
Troy CenterTroy Center

I have a result... Chris Emmett (above) posted the correct Case Creation details above, which I didn't use, but got the same result. As you can see, my badges have appeared. Ana from tier 1 tech support called me and her tier 2 engineers told her what email address was associated with my Trailhead account. It was an old, but still active alias from my old domain. I still had access to it, so I was able to associate the account. I have now used Chris' fields above to create a case to update my email address. I can't figure out where to see it or how to update it, being my email address, in Success.Salesforce.com without contacting support. 

I think... correct me if I'm wrong... Success.Salesforce.com is acutely tailored and may be restrictive on purpose to allow for more granular moderation of profiles. I forgive the inconvenience if that is the case. Otherwise, they should fix this, but you could open a case, if so inclined. 
 

Rohan PradhanRohan Pradhan
I think I'm facing somewhat similar problem.

Trailblazer profile info disappeared and now can't connect trailhead to trailblazer?
User-added image
I had completely setup profile for Trailblazer with profile pic, following, trailhead badges linked, about me information, and yesterday when I logged into trailblazer, all the information had disappeared, and only my first and last name was existing. I use same email id for trailhead and trailblazer.

And now, when I'm again setting up my profile for trailblazer, my trailhead account is not getting linked to trailblazer. 

However, I'm still in confusion, where, in first place, did my trailblazer account information go? I rechecked again and again.

P.S. - I have same email id, same username for my trailhead as well as trailblazer account
Christine MarshallChristine Marshall
Hi Rohan,

You might want to log a case with Salesforec about this.Are you definitely logged into the correct account? 

 
Troy CenterTroy Center
Rohan, I have seen this and I can reproduce it.

My RCA:
You have another success.salesforce.com profile that has your trailhead and/or webassessor connected to IT. You need to disconnect from that success.salesforce.com account first, or go back to using THAT one. (Lots of people have more than one profile from past jobs). 

For example, I have two success.salesforce.com accounts. I cannot connect WebAssessor or Trailhead to my "personal" profile because they are currently tied to THIS, my "MCG" profile. 

If you cannot access any other success accounts, you need to open a support case from your Help & Training link and answer the phone when they call you. They will be able to find the other success profile and disconnect it but it might take a week or two. 

Troy

User-added image
Rohan PradhanRohan Pradhan
Thank you Christine and Troy.
I tried all means yet same problem. I tried to raise a support case. However, in the Help and Training section, I'm not getting any option to create a case or log a case. Even on clicking Contact support, I'm asked to log in and then direct to same Help page again and again. I spent entire week to figure out, how to raise a case and checked all possible options. I think I should directly call Salesforce.
Christine MarshallChristine Marshall
Hi Rohan,

From the Trailblazer website, click on the Help tab and then on the case button - you will need to login with a production account not your personal developer login. Do you work in a live Salesforce org? Use those credentials to login to see the support options.

Christine  
Rohan PradhanRohan Pradhan
Thank you Christine. The problem got solved. I, actually, sent an email to 'trailhead@salesforce.com' explaining my case and after exchanging few emails with the developers team it got resolved and now I can see all my badges linked to my trailblazer account.
Christine MarshallChristine Marshall
Glad you got it fixed!! 
Chris BradyChris Brady
For some reason, when I try to trigger the 'confirmation code' to a role-based email address (marketing@domain.com) associated with my Trailhead progress, the mail is not getting through. Putting in a Gmail email address works instantly. Any advice? 

I am trying to connect my partner profile with my trailhead profile. Thanks!
-Chris
Christine MarshallChristine Marshall
Most likely has somthing to do with your company's email setting I would think. It might be in your junk folder. If not, it might be being blocked by your IT email settings. Best to speak to internal IT. 
Chris BradyChris Brady
Thanks Christine - When sent to a role account, the email is not appearing anywhere in our IT system. I wonder if the notification system used for sending the triggered emails is running through some logic that is not allowing it to send to a role account (makes sense for outbound spam prevention reasons) but in this case I am a real person...hmm thanks!
Christine MarshallChristine Marshall
That's a tricky one then...maybe log a case with Salesforce if this is going to cause you issues? 
Trev RaicesTrev Raices

It turns out this is a bug, I've been back and forth with support all week as it's driving me nuts.  Very frustrating.  I'm trying to use one login/ID for all.

Just an FYI :) Link Trailhead Error
Chi NKChi NK
Party on,
I got the same issue and followed the instruction here is log a case. Just a few hours, I got an email from Ravindra said my Trailhead email is already connected to the other community profile and forwarded my case to community team. After removing from an old community profile, now my profile was linked. Moreover, I got the issue when linking Trailhead to Webassessor Account for my credential maintenance, but now it solved. 

For those who have more than one community profile like me, could check the connection, maybe It'll be solved. 
Devin ComptonDevin Compton
Has anyone experienced the amount of badges and points being incorrect when linking the Trailhead account to the Success/Community account? It looks like all of my badges from April 2018 - October 2018 are not showing up accurately on my Community account, but on my trailhead account the number is accurate. Screenshots below

Community Profile
User-added image

Trailhead Profile
User-added image

Any solutions, links, ideas, etc. are welcomed. 

Thanks in advance!
Christine MarshallChristine Marshall
But weirdly your points are correct?! Some badge don't show up because they are community badges but this would only account for 1 or 2. With that amount missing, but the point score working, I definitely think a chat with Trailhead is in order...
Carole BennettCarole Bennett
I have a similar issue, but both badge count and points are incorrect. Incredibly frustrating!
Christine MarshallChristine Marshall
@Carole how many badges are missing? If it's 3 or 4 then they could be community badges which don't show up. 
Carole BennettCarole Bennett
@Christine - all but one. Basically, it shows the very first badge I earned, but not the 36 others.
Christine MarshallChristine Marshall
Sounds like a question for Trailhead sadly. Good luck!
Heidi FryzellHeidi Fryzell
Don't use the email above (trailhead@salesforce.com), looks like they switched it to "no-reply". I had to open a case. Thanks!
VenkataAdithya KenchamVenkataAdithya Kencham
Hi @Rohan Pradhan, I see that you had issues in the past related to badges in Trailhead profile. Now I'm unable to see any of my badges in the profile nor the points acquired. If possible could you please help me with the troubleshooting steps you had to resolve this issue. Thanks in advance. 
Leland GuthrieLeland Guthrie
Thank you Christine and Troy.. I got the same issue and followed the instruction here is log a case.