Log a Call button does not appear in Lightning Activities - Answers - Salesforce Trailblazer Community
Ask Search:
Bridget AbercrombieBridget Abercrombie 

Log a Call button does not appear in Lightning Activities

After a little research, I have tried everything and the log a call button still does not display in the Activities component of Lightning.
  • Log a call been added to Salesforce1 and Lightning experience Actions
  • No activity record type
  • Global Publisher layout includes log a call
  • No additional buttons have been created (so no duplicates)  
Not sure what else to try any help is appreciated. 
Best Answer chosen by Bridget Abercrombie
Bridget AbercrombieBridget Abercrombie
Finally got it to work after finding this knowledge artical:  https://help.salesforce.com/articleView?id=000247872&type=1
For what ever reason in the Global Actions it was not showing "Task" in the record type field.  Once added it worked.   

All Answers

Patrick SullivanPatrick Sullivan
Are you using a standard button, action, or something custom? Are you seeing the record appear on a related list, but just not in the feed?
Bridget AbercrombieBridget Abercrombie
I am using the standard activities section in Lightning and have not created a action or button.  Log a call use to be on the page layout so it does appear in the timeline, just not ano option to select anymore on the layout.  I also tried removing the activities and replacing, but that didn't work either.   

User-added image
Bridget AbercrombieBridget Abercrombie
Finally got it to work after finding this knowledge artical:  https://help.salesforce.com/articleView?id=000247872&type=1
For what ever reason in the Global Actions it was not showing "Task" in the record type field.  Once added it worked.   
This was selected as the best answer
Patrick SullivanPatrick Sullivan
Great! Thanks for posting the solution. That helps people in the future!
Stuart McClainStuart McClain
I keep seeing the answer published - but I just CANNOT get it to work.
when I click Edit by any of the missing global actions, such as EMAIL or LOG  A CALL - there is nothing there regarding RECORD TYPE.
however, one page layout/record type does include the actions in ACTIVITY - but this one record type will not - even though I have put all the QuickActions and SF1/LIghtning action buttons on the page layout.
Ken TallmanKen Tallman
I'm with you Stuart. I don't see any Record Types, and can't find any way to get the Log a Call action to display in Lightning in the Activity History component. If you ever figured this out, please let me know how.
Sean BookSean Book
If you do not see Record Types when attempting to edit a Global Action, go to the page layout for your object and add 'Log a Call' to the 'Mobile & Lightning Actions' section of the page layout.
Ajay VermaAjay Verma
New Task and Log a call works in few profiles along with one of my custom action , and for others it doesn't,  I even tried assiginng those users the profiles for which these actions are working, but of no avail.  
Robyn MerckxRobyn Merckx
Ajay, I had a similar issue; try going to Object Settings in the affected profile, selecting Tasks, and in the Record Types and Page Layout Assignments section, make sure that if there is more than one record type, the right one is selected. Mine were set to Master; I had to switch them to the Task record type. 
Danielle HenriquezDanielle Henriquez
Wow @Bridget Abercrombie you saved me with linking to this knowledge article: https://help.salesforce.com/articleView?id=000247872&type=1 (https://help.salesforce.com/articleView?id=000247872&type=1" target="_blank)

I too had added the action to the appropriate section on the page layout but was still not able to see the change. Once I updated Global Actions it worked. Thanks again :)
Tim KocherTim Kocher
Follow up Question to this group...Did Salesforce depricate the "call" icon in mobile?  It used to be there.  Hit it and you'd call the number listed for that contact.  It would then automatically take you to the log a call screen.  But I can no longer find the phone icon.  Did they drop it? 
Bridget AbercrombieBridget Abercrombie
@timkocher, Just happened to see this artical that may answer your questions.  Check it out here:  http://www.simplysfdc.com/2018/08/salesforce-lightning-log-call-button.html  (http://www.simplysfdc.com/2018/08/salesforce-lightning-log-call-button.html)
Stephen ChilcoatStephen Chilcoat
I have gone through all of the solutions mentioned and I still can't get it to work.  My profile has access to all of the record types.  I also verified that the Task object is using the correct record type and the button is pulled into my page layout.  Still nothing shows up.
Denis AbrantesDenis Abrantes
Do you need Admin permissions to add this link? I can't find the Setup page described in the document. Extremely frustrating not being able to do something as basic as registering a new activity!
Bridget AbercrombieBridget Abercrombie
@Denis Abrantes,  You do need Admin Permissions to make the changes outlined in the Knowledge and Help Articals.  Work with your Administrator to make the necessary changes so that you can quickly and easly create your activities.  
Elise SaenzElise Saenz
Did anyone else have the issue happen only on a certain object but not on others?  When adding the Activities component as a tab on my Opportunity lightning page layout, the "Log a Call", "New Task", and "New Event" buttons show up.  However, on the Account, with the same component setup, I only see "Email" button.  I went through the steps in the knowledge article, everything's setup correctly.  I'm an admin so should've have visibility to everything. 
Archie AntilArchie Antil
Did you resolve this, i have the same problem. thanks in advance. 
Randi RabeRandi Rabe
Are there any other settings on the profile that would prevent users from seeing these actions? I have checked all settings and some of the profiles see the action and some don't and I can't figure out why.
Stephen VorisStephen Voris
Ran into this myself today; I (as an admin) could see the "log a call" tab, but the guy who was actually supposed to do the call logging couldn't. Problem turned out to be the "record type" one: there were existing record types for tasks, only he hadn't been assigned any of them. 
Where I looked:
Object Manager > Task > Record Type (confirming that there was at least one; in this case there were four)
Object Manager Case > Page Layout (confirming it was actually on the page, though this was already ruled out by my being able to see it)
Global Actions > Log a Call > Edit (confirming that it showed up for said record types)
Profiles > (Relevant Profile) > Record Type Settings > Tasks > Edit (moving it off the "--Master--" option; this is what fixed it).
Bee VangBee Vang
In LEX, global actions need to be assigned a record type other than Master. Once this is done,  you will see the action appear in the activity once a user has been assigned the type. 
Elizabeth PeggsElizabeth Peggs
@StuartMcClain did you ever sort out how to get the record type to show itself.  I am so surprised that it takes this much work to get "log a call" on to the contact form.... seems like it would be a default setting! Thanks in advance for any sanity you can offer. 
Donna WhitigDonna Whitig
Not sure if anyone else had the same issue as me but my issue was that the Actvitites View needed to be set to Activity Timeline.  Posting link here in case it helps anyone else:  https://help.salesforce.com/articleView?id=customize_records_record_activities_view.htm
Alex PylypenkoAlex Pylypenko
I am having the same issues as Stuart, Ken and Elizsbeth with no 'Record Type' option. Has anyone solved that particular issue?
Nkosilathi NcubeNkosilathi Ncube
Edit the page layout of the object and Add Log Call button from both Quick Actions and Mobile and Lightning Actions
Alex PylypenkoAlex Pylypenko
I raised a Case with Salesforce and they said there was an issue with our system, possibly due to an installed package (I think I know which one to blame!).

Basically, I had to recreate all the buttons (global acitons) as per their recomendation as the standard ones were not functional and that did the job. 
Drupad ChittaluruDrupad Chittaluru
Hey all, I knew it is a very late to comment now on a post that is posted in 2017 and ended comments in 2019.

To start, I am one of a representative of Salesforce team in my company, and one of my user had the same issue, everyone else in that profile were able to see that component, but one particular user was not able to, I checked all of the record types, page layouts, lightning page layouts etc., everything which topped my head were perfectly fine, I digged it more and saw that it is a personal setting for an user in their own login(profile) 

They have to go to their settings by clicking their avatar on the top right corner of any SFDC Page, and then go to Display and Layout section and chose Record Page settings make sure that they view is set to "Activity Timeline". 
Hopefully this should help at least few of the people in here.

User-added image
Natasha MattesiNatasha Mattesi
Hi all! I'm still having issues. I have Log a Call and New Task in all of my other objects, except for Opportunities. I did everything I did with the contacts/leads/accounts but for some reason opportunities just aren't showing the log a call or new task buttons. Every time I try to change it, it just goes back to what it was. I also tried changing the page, and when I tried to change it and save it would say it saved, but when I go back, the page isn't updating. 

Any suggestions?
User-added image
Drupad ChittaluruDrupad Chittaluru
Hello Natasha, when you said, changing the page? did you mean that you went into the Lightning page editor and added the component?
Natasha MattesiNatasha Mattesi
@Drupad - yes. I went to the page editor in lightning and added it to the side. but then it doesn't show the buttons, and when I try to change it and add it back to the center, where details and chatter are, it says it saves, but the view doesn't change. And when I go back to the editor, those changes don't show having saved on the backend either. :(
Bridget AbercrombieBridget Abercrombie
Hello @Natasha - To confirm you updated the appropriate Opportunity Page Layout (not lightning layout) and added the log a call and task in the Salesforce1 and Lightning experience Actions section.  Did you also update in Global Publisher layout?  If  you are not using record types and both of these have been completed, it should display on the page.   
Natasha MattesiNatasha Mattesi
I did it in the Page Layout and also Lightning layout and neither way is working. I also went and updated the Global Publisher Layout. Not sure what I'm missing, but I'm sure its something simple and I'm going crazy.