Ask Search:
Roshan KhoteleRoshan Khotele 

Test Drive - Issue while login for taking test drive for listed app

Test drive issue - we have application listed on AppExchange. For setting up the test drive for same application, we logged into AppExchange using the credentials for your AppExchange Publishing Organization (APO) and followed the steps given below.
1. Clicked on name in the upper right corner and selected Publishing Console.
2. Clicked the Uploaded Packages tab and got package version
3. Clicked on Edit Listing next to the package version.
4. Clicked the Offering Tab
5. Clicked Create Test Drive.
6. From the pop-up, entered a title.
7. Selected the package. It installed in a new Developer Edition organization.
8. Clicked on Submit.
Received an email with login credentials for a new DE organization
1. Logged in as the administrator to the new organization and created sample data.
2. Logged in as the evaluation user to define password.
3. Logged back into AppExchange.
4. From the Offering Tab, under Test Drive, clicked on Change Organization to specify the new DE organization.
5. Entered the evaluation user's login and password that was sent to me with the administrator credentials. The evaluation user has read-only permissions.
6. Clicked on OK and then Saved.

When I tried to click on "Take a Test Drive" button, it asked me for user name and password. but whenever I tried to submit my user name and password it shows me error and does not allow to proceed.
Best Answer chosen by Miglena (Salesforce.com) 
Roshan KhoteleRoshan Khotele
Hi Jeff, we got the solution.
The password which we set for eval was not correct. Password should not contain special charecter and we used that in our password. Now its working fine after changing the password.

All Answers

Jeff MayJeff May
Are you the Package vendor trying to setup the Test Drive?  Or are you trying to use a Test Drive from another vendor?
Roshan KhoteleRoshan Khotele
Jeff, we are the the package vendor. We developed this app and now currently it is listed on AppExchange. 
Jeff MayJeff May
When use are setting up the Test Drive, you'll use the admin@ username and password you setup for the Test Drive org.  Then, when you define the Test Drive org in your publisher listing you provide the eval@ username and password.  This eval@ is the credential used when customers take a "Test Drive"
Roshan KhoteleRoshan Khotele
Hi Jeff, we got the solution.
The password which we set for eval was not correct. Password should not contain special charecter and we used that in our password. Now its working fine after changing the password.
This was selected as the best answer
Iain Clements ☁Iain Clements ☁
Hi Roshan, I just wanted to say thanks for posting your solution.

Even though your reply was from 2014 I experienced it yesterday and the fix was exactly how you describe. Crazy that you can't put a special character in the test drive evaluation password - perhaps because it's passed through the URL from AppExchange to the new window.