Ask Search:
Dave PerryDave Perry 

Salesforce for Outlook - Cannot start Microsoft Outlook. A program error occurred

Hi All

All pc's running Windows 7 Pro (64bit) with Office 2007 SP3 (fresh installs from DVD – not imaged)

We have noticed that since upgrading our Salesforce for Outlook add-in (v2.2.6.8 and v2.3.5) approx 6 users out of 40 have started to receive the error when starting Outlook.

Error
"Cannot start Microsoft Outlook. A program error occurred. Quit Outlook and Microsoft Windows and then start again".

No errors in the sync log and sfo works as it should

If the user clicks OK the message disappears and then outlook behaves normally.

Things I have tried:
Uninstalling SFO and the error no longer appears.

Reinstalled SFO….
Repairing/Uninstalling (plus uninstalling pre-reqs) and installing latest SFO - same error
Repairing Outlook - same error
Pc MS and Office fully patched - same error
Deleted DB folder – same error
Uninstalled SFO and re-installed v2.2.0 – same error
Uninstalled SFO and pre-reqs and re-installed v2.2.0 – same error (which as far as I am aware – we never had any reported issues of this error on this version before the upgrades)

Any further ideas/suggestions welcomed 
Bill GreenhawBill Greenhaw
I will add one more to you list to try. Completely uninstall Salesforce for Outlook..meaning all registry data, etc... Some things stay around even after an uninstall.

https://help.salesforce.com/HTViewSolution?id=000003884&language=en_US (https://help.salesforce.com/HTViewSolution?id=000003884&language=en_US" target="_blank)
Dave PerryDave Perry
Hi Bill, thanks for advice.

I tried the uninstall and re-install exactly as the documents described (adding admin rights, disabling AV etc etc) but still the same error message when outlook is started for the first time (doesn't appear if you just close and re-open outlook)


Eventviewer at the time of the error  has one error listed in System
"The server {0006F03A-0000-0000-C000-000000000046} did not register with DCOM within the required timeout" - ID 10010

I do remember seeing an article reference this on salesforce and tried the suggestions but that didnt work either (tried on another pc a few weeks ago). Other than that, google didnt really come up with much on it!
Dave PerryDave Perry
Logged this with Salesforce as a case - thought it was fixed by uninstalling SFO and then installing using the MSI (rather than exe). However after 1 week, 2 people had the error return. Re-opening the case for further investigation.
Amanda RoseAmanda Rose
We have also logged  a case for this.  Is there an updated fix for this?
Jeff LevyJeff Levy
I've had a case open for two months about this issue. Tried various troubleshooting steps with no success. Does anyone have an update? Did 2.5 fix the issue?
Freddie JoyceFreddie Joyce
This is affecting several of our users too. Would be interested in any updates.
Jeff LevyJeff Levy
I just installed version 2.5 which is a part of the Summer '14 release and it appears the error message still appears. I've tested with a corporate build of Windows 7 (64-bit) and a vanilla copy of the operating system. In the latter, I only installed Office 2007, SFO, and logged into the plugin (I did not add my email address) and still had the issue. This is clearly a problem with the code behind the application. I still have a case open with SFDC (coming up on 3 months), and will be sure to provide updates as they become available.
Dave PerryDave Perry
We still have the issue here but the users have learnt to live with it for a while. SF support wasnt great and was going round and round in circles answering the same questions and doing the same things and completly ignoring anything i wrote above. I thought it was just our company but seems like it is more widespread.
Dave PerryDave Perry
Thought i would give this another go after nearly a year! - we are now on Winter 15 and the latest SFO is v2.6.1. Only just installed the new SFO but so far so good. However will test throughout the week. Is anyone else had this resolved yet by a later release?
Dave PerryDave Perry
Upgrading to Office 2013 and v2.71 resolved these issues