Ask Search:
Mary AngertMary Angert 

What is the Flex Error #1001: Digest mismatch with RSL error mean and how fix?

Users are getting the following error when working in Libraries:

Flex Error #1001: Digest mismatch with RSL https://na11.salesforce.com/_swf/121310/sfc/flex/framework_3.5.0.12683.swf. Redeploy the matching RSL or relink your application with the matching library. 

What is the error and what is the fix?

I haven't found much information about this issue.
KC ShaferKC Shafer
Sounds like a flash error, might want to take a look on the adobe forums here: http://forums.adobe.com/thread/258374 .

Did you just upgrade your player?
--KC
Alexander SalatzkatAlexander Salatzkat
Hello KC, unfortunatly the tips in that forum are helpless (besides that they are from 2008).

Her is what I tried and what is NOT helping.
- Reinstall new or older Adobe Flash Versions
- Delete all cookies
- Start browser (I used Explorer, Mozilla and Chrome) in the "private" mode
- Start from another Computer (my private one at home)
- logged in as another User.

Salesforce claims it is an Adobe problem, does any of you have these problems too. Just go to object "Libraries" , click on "Create new..." and then choose "Content Pack".

Any help or suggestions are welcome.

Thanks,
Alex


Michael SkubiszMichael Skubisz
Interestingly, on my MacBook Pro I see this error under Chrome but when I use Safari it works fine.

Mac OSX 10.7.5
Chrome Version 23.0.1271.64
Safari version 6.0.2


Chrome has Flash player 11,4,402,265 installed
Safari has Flash Player 11,5,31,2 installed


Mike LyonsMike Lyons
Anyone have luck fixing this error?  I have been working with SalesForce support on this exact issue and we have made no progress.  When I click the "Create New Content Pack" on the libraries screen I get the error.  I have tried multiple computers and browsers (IE8, IE9, Firefox, Chrome).  It works just fine for the SF support team.  I have reinstalled Flash, cleared caches, installed old versions of Flash, and used every computer I can get my hands on.

Any ideas?

Thanks,
Mike
Laurent MartinacheLaurent Martinache
Hi 
we are experiencing a similar error message in our production org. 

01: Digest mismatch with RSL https://emea.salesforce.com/_swf/121310/sfc/flex/framework_3.5.0.12683.swf. 
Redeploy the matching RSL or relink your application with the matching library.

 
Salesforce has identify this a a bug . If needed, you can refer to salesforce.com premier support using KONE references:
***Child Escalation to Backline - 08592988***
Case 08521154 - Flash / Content
bug W-1297593

We are expecting quick resolution from Tier3


Mike LyonsMike Lyons
L.Martinache,
  Thanks for the reply.  I also had a support ticket open with SF.  After a couple of weeks they gave up and told me it was a problem with Adobe, they don't support Adobe, and closed the ticket without a resolution.  I hope you get a better response and if you do please reply.

I can tell you that I am continuing to test the issue.  I am able to get everything to work correctly from my home machine.  Taking my work laptop that fails at work to my home network still fails.  There must be something at the OS level that we have set on our work machines that is causing this error but I have not been able to find it yet.   What little you can find onlie says that you should clear the Flash cache from the control panel to get past this error.  However that does not work in my case.  Others have said that they get the error only from users accessing the internet via a VPN but again that is not the case with me.  

If I do finally find a solution I will post it here.

Thanks,
Mike


Alexander SalatzkatAlexander Salatzkat
Mike I agree with you, the problem lies somewhere between Salesforce and the companies restriction, but unfortunately for both of them it is not too important.
Mike LyonsMike Lyons
I now think this is completely on the SF side and has to do with how they have built the control. I noticed that the Flash cache on my work pc was empty. I thought it was going to be a problem with how my work pc was setup that was either preventing the framework files from being downloaded to the cache or something on my work network. I went back to my home pc where everything works just fine. On that pc I cleared my flash cache so that I could see which files were downloaded for this page. Now my home pc gets the same error as my work pc. I believe that SF has created their flash control incorrectly so that the base flash framework files are not available. I believe it worked on my home pc previously because these files were downloaded from another site. I cannot prove this since I cannot get the home pc to work again either.

At this point I am giving up. I am very disappointed in SF and their support. We pay for premium support and do not get the value we should from that support.

--Mike
Mike LyonsMike Lyons
I was able to get past this error by doing the following on a pc that is getting the error:
1) Select any content item in the library
2) Select "Deliver Content" "Deliver this content" from the content details
3) click "Save and Next"
4) Click "Preview"
After following these steps I no longer get the error when trying to create a new Content Pack from the libraries screen.

If you close all browser windows and clear the Flash cache via the windows control panel flash program you will start getting the error again until you follow these steps.

I have a new support ticket open with SF to get them to address this problem. 

I hope this helps anyone else seeing this error.

Good luck,
Mike


Pilar FonsecaPilar Fonseca
Thanks Mike, your solution works for us.

The problem here is not Adobe, the problem is Salesforce. How can they develope the content module in "flash"????? Flash is for animations.

Salesforce told you they don't support Adobe???? How can someone give that answer after they are making us using it????

Come one Salesforce stop giving those ridiculous answers and move the content module to HTML5 as you should do from the begining !!!
Steve KingSteve King
No answer, but I am having this problem too and looks like SF not helping.

I was looking because one of our users is getting the error. I was not getting the problem myself on IE and Firefox, but I tried clearing my Adobe cache from Windows Control Panel Adobe and now I get the problem on both browsers plus Chrome (I didn't check Chrome was working in the first place).

I've tried looking at Flash content on another web site but that has not helped (not sure why I though it might!)

Previewing existing content fixes it.
Andrew LeeAndrew Lee
This could be totally off the track here, BUT....   I was getting the same Error (Flex Error #1001.....) when attempting to Deliver Content from "Library XX" which I had created myself (and set myself with the standard Salesforce "Library Administrator" permission.)     I assumed that this would give me pretty much full rights (including deliver content), but after double checking i realized that it did not.   When I changed my Permission for "Library XX" to "Author" and then went back to try delivering the content, i no longer received this error.    This may not fix everyone's issues here, but it worked for me. 

Cameron LoweCameron Lowe
I realise this post is 2 years old, but as a Flash developer I figure I can answer the question anyway.

First of all, Flash is NOT just for animations. Most Flash work today is for business RIAs (rich internet applications), although it may be slowly diminishing in popularity since the advent of HTML5. But I digress...

These errors occur when RSL libraries (externally compiled libraries, like a Windows DLL) used by another, separately compiled, Flash application were not compiled with the same SDK. It is unlikely whoever produced the compiled Flash content forgot to release all the latest versions of the RSLs with the applications that use them, so I would be suggesting the issue came down to caching of the old RSLs by either the server or (more often the case) the local browser. So when the new application loads up and goes looking for the RSL, it is given an old copy that causes this error to spit out.

I don't know where Flash is still used in Salesforce (since I'm only new to this platform), but I do see errors frequently when browsing the web pages that pop up because I run a debug Flash Player plugin in my browser. So it's still there somewhere...

Hope this helps to explain these errors belatedly :)
Mary AngertMary Angert
Thank you for the reply. My user recently received the message again. I will pass this on to her. [US_email_logo] Mary E. Angert Principal System Analyst/AVP – Application Support Salesforce Certified Advanced Administrator Salesforce Certified Developer CSI Leasing, Inc. tel 314.810.8919 or 800.997.7010 x151 fax 314.997.7852 skype mary.angert Website www.csileasing.com [thinkgreen]