Ask Search:
Kevin SuiKevin Sui 

Excel Connector

I have installed the SForceOffice in order to make use of the (Word, Excel) Salesforce connectors. After installation i can't see the Menu SalesForce in Excel  which will enable to Login to Salesforce.
However i can see it in Word.
Why is that missing? and how can i troubleshoot that?
Matt BrownMatt Brown
Depending on your Office Edition you need to open Excel and get to the Add-Ins section.

For Excel 2007 you would select the excel button at the top left>look to the bottom of the pop-up menu for "Excel Options" and select>Add-Ins from left sidebar>select Go at the bottom next to the Manage Excel Add-Ins dropdown>select Browse (locate your Sforce-Connector folder you downloaded and open it to the sforce_connect.xla and highlight it)>click OK>make sure that Sforce_Connect has a checked box and select OK>select the Add-Ins tab and you will see the sforce Connector option.
Kevin SuiKevin Sui

My excel Version is 2007.
Yes i go to manage add-ins and browse

However i can't see any sforce_connect.xla (search for *.xla in the but could not see any)

Directory structure is as follows
Program Files\\O3
Program Files\\Office Edition
Program Files\\Office Toolkit
And there are a number of Dlls, but no xla files.

Matt BrownMatt Brown
Ok you need to go here and download the Excel Connector from this location. Download it to wherever you you download files too and unzip it to the same location. When you browse for the sforce_connector.xla you will be looking for it in the location of your download.

Let me know if that does or does not work for you.
Jill LarsonJill Larson
Me too! Did you get an answer?
Keith AdamsKeith Adams
My salesforce connector stopped working after years.  I get an error message:
"An internal server erro has occured while processing your request.  URL:/"
Anyone know how to fix this.   Does it still worrk for you or did SFDC do something to disable the functionality?

Asish SharaffAsish Sharaff
Hey Keith

be sure you are adding your security token after the password when logging in.  If you don't have your token, you can get it by going to Setup | My Personal Information | Reset My Security Token
huy buihuy bui
Hi Keith,

I get the same error message: "An internal server error has occurred while processing your request.  URL:/", when I try to login with my Sandbox account. Then I try again with my Production account, it works correctly. It may be your issue too.
Akshay BirlaAkshay Birla
I am using Windows 7 Professional (64-bit), Salesforce Unlimited, and Excel 2010 and also having trouble using the Excel plugin.

First I downloaded it from the website by going to My Username > My Profile > Desktop Add-Ons > Connect for Office and clicking "Install Now"
Initially it seems like the installation has taken place but when I open Excel I can't see the tab

Next, I tried to go to and I downloaded the connector, "" (it seemed like the most recent one). I then unzipped it in the folder and tried to add it by going to "Manage Excel Add-Ins" in Excel and add this. However, I get a compile error when I'm doing this.

Is anyone else having similar difficulties? It looks like this thread died out mid-year last year so I'm wondering if people have given up or have figured it out. Would appreciate any help.
Daniel HurranDaniel Hurran
doesn't look to be working on 64 bit office. Last time I had it working was on 32bit office.
Andrew LairdAndrew Laird
I was able to download and run the SForceOffice.exe.  I was also able to get the sforce Connector to show up as a menu item in the Add Ins tab of Excel.  But when I try to open up a new Sforce Table Query Wizard, I get the error below.  Has anyone else run into this error?  I am running Excel 2013.

"Cannot run the macro C:\Users\etc,etc\sforce_connect.xla's DecribeAndQuery.  The macro may not be available in this workbook or all macros may be disabled."