Ask Search:
Lihod RachmilevitchLihod Rachmilevitch 

Timba survey for external users (using Salesforce sites)


I'm testing TimbaSurvey app in my sandbox, I've followed their tutorials and the survey is configured properly.

I'd like to send the survey to external users, so I've configured Salesforce site, from this point I'm facing a permission issue as described in the picture below:
Timbasurvey error

Your assistance is appreciated.

Best Answer chosen by Lihod Rachmilevitch
Brent DowneyBrent Downey
Ensure that your site is correctly configured. You can find the site setup here on Timba's support page:

f you are still having trouble, contact Timba Support. They are very good at getting back to you in a timley manner and can very quickly find a resolution!

All Answers

Brent DowneyBrent Downey
Ensure that your site is correctly configured. You can find the site setup here on Timba's support page:

f you are still having trouble, contact Timba Support. They are very good at getting back to you in a timley manner and can very quickly find a resolution!
This was selected as the best answer
Lihod RachmilevitchLihod Rachmilevitch
Thanks Brent, I followed these instructions but unfortunately I could not solve the problem.

BTW - I already sent an email to their support on Friday, no response until now :/

Thanks anyway
Dan CallahanDan Callahan
Did you ever find a resolution for this?  We're having the same issue; double checked to make sure the site is setup proper but still no luck.
Rajeev LohaniRajeev Lohani
You need to change the status of the survey to green by clicking on collect and in the collection settings mark collection and anonymous collection status as on.
Tiffany ChenTiffany Chen
I'm having the same issue as well. I followed Timba Survey's knowledge base and configured the permission settings (double/triple checked). I also added a sharing rule for the Contact Object (site guest users can see all internally owned contact records). I also checked that all objects are properly deployed in the Object setting. I'm still getting the same error message above.  

@RajeevLohani, i changed the survey status to green based on your feedback but am still getting the error message.

I also sent two emails to timba survey support and haven't heard back from them. I sent it to and Is this the correct support email?
Arun RamachandranArun Ramachandran
Same issue for me as well.... Double checked the permissions given on objects... set collection anonymous to green... not sure what is missing... I too have dropped an email to Timbasurveys to get this issue resolved..
@Tiffany Chen: Any chance you got a reply yet?
Arun RamachandranArun Ramachandran

Hi Everyone..

just redid the procedures mentioned in the deck in ""

Follow the steps mentioned to the last word...... go through all the slides one by one.. enable permissions exactly the way they have mentioned in the slides... not a single permission extra not a single one less... All the objects they have mentioned in the site.. ensure have the permissions as mentioned in the slide... 

I just accessed my survey through the sites... 
Works perfectly fine!!!

Hope this helps...


Tiffany ChenTiffany Chen
@Arun Ramachandran, my issue is still not resolved. I just folowed the configuration guide ("") for the 4th time - step by step, not a single permission extra, not a single one less, double-checked, triple-checked, quadruple-checked... still getting the :Authorization Required" error message. 

Timba Survey support got back to me, asking me the version number of the app and some other details. I replied back and now am still waiting for support to get back to me. 

Any other tips you can think of? Or anything else that I'm missing?
Arun RamachandranArun Ramachandran
Ok.. Perform the following steps.. this is what I did.. once you are done with the configuration in the deck above:

1. Once you create a sample survey using Timba Surveys app... after you save... notice the URL has a salesforce ID somewhat like this marked in bold ''

Just after saving you will notice a Setting Icon beside a question mark on the top right hand side of the page. Click on it, ensure you mark Site configured checkbox as true and also paste the default site URL over there. In my case i pasted my Site URL (

2. Once you have configured your site properly... copy the default URL of the site which will look somewhat like this (in my case):

3. When you try to access the Survey using sites:
Use the following URL:
the ID at the end, is the ID showed in bold in point 1.

Let me know if that works?
Tiffany ChenTiffany Chen
Thanks Arun! 

I followed your steps and got directed to an 'under construction' page (instead of an 'authorization required' page). I believe this is because the 'UnderConstruction' visualforce page is set as the site home page based on the slides. Should I set the home page to something else? 

Under Construction

Site details
Tiffany ChenTiffany Chen
I got it to work! It turns out that in addition to creating a sharing rule on the Contact object, I also need another sharing rule on the Case object, where the survey is being generated from. 

Thank you for all your help!
Arun RamachandranArun Ramachandran
Cheers Tiffany!!
OCP AdministratorOCP Administrator
I am having the same problem went through the same steps.  I am not sure what you mean "creating a sharing rule on the Contact object, I also need another sharing rule on the Case object, where the survey is being generated from"... Could you let me know in detail what you did here because I don't see any sharing settings that pertain to public access. Thank you.
Tiffany ChenTiffany Chen

this should give you some details on creating the sharing rules. The slides show you the steps to create a sharing rule on the Contact object. In my situation, I needed to create a similar sharing rule on the Case object because that's where my survey was being triggered. 

Let me know if this helps.
Lalit ChauhanLalit Chauhan
Hi Arun,

Do I need to create a site page? Please let me know be giving as Active Sit Home Page. It would be really helpful.

Alka TanejaAlka Taneja
Hi All,

I am facing the some issue. I have couple of questions :-

1) What should be the 'Active Site Home Page' ?
2) I am getting alert message that 'sorry, you have reached your daily email limit. We have....'.

Please guide me on above issues.

Susan ThayerSusan Thayer
@alka taneja  You don't have to build a custom site home page, "under construction" will suffice. So long as everything else is set up properly the Home Page would never display.

You might want to open up a separate Question regarding your second bullet and provide more details.
Susan ThayerSusan Thayer
Just to elaborate a bit... you're not actually sending anyone to your home page. Instead you are sending them to a subpage of the site that contains the survey. 

The url you are sending them to is your site followed by the survey id. (ie ). In theory though, someone could see the url and decide to manually go to if that is the case then they would get the under construction page.  To ensure superior service you could always redirect that page to your main website page.

My point on my earlier comment is that the "under construction" page would not be the cause of the survey not working.
Tiffany ChenTiffany Chen
Me again. I'm deploying Timba Survey in our full sandbox and have to repeat all the steps again in this full sandbox. I'm again seeing an error page "Authorization Required" when I click on the survey link. 

I followed the online knowledge base and did the following:
1. Created Contact object sharing rule and Case object sharing rule based on this link:
2. Adjusted settings based on the Sites configuration link:
3. Confirmed that the application is properly deployed based on this link:

I have also made sure that the survey collect status is set to green, and that Timba Survey configuration has both “Log Enabled” and “Site Configured” checkboxes checked, with the Site URL being the Salesforce Site URL.

Am I missing anything? Could you help me further troubleshoot to make the survey link available for external users? Any help is appreciated!
Igor TomilovIgor Tomilov
@Tiffany Chen I had the same problem couple days ago. In my case the problem was in the template that is used in my workflow - at first I took the default Timba template [Send using Workflow]"name of your survey". If you open that template there is formula that chooses what link to input in the email and non of those links lead to the created "". They all lead to"survey id" and this adress requires salesforce login.

My solution was to create a custom html email template and input the link to my survey from Collection Parameters of your Timba page. Go to TimbaSurveys Tab -> Click on you Survey ->Collect ->Switch on "Collection" and "Anonymous Collection", below the "Anonymous Collection" there is a "Current Survey Link:" this is the link you need. To create a custom template go to Setup -> Email -> My Templates  and create a desired email template pasting the link that was previously copied, update your workflow rule choosing the created template.
Hope this helps!
Paula PetersonPaula Peterson
Does anyone have real information on how to get a hold of this company? I tried a few of the links in this list and I always get an error that the page no longer exists and then it flips to

No help desk at

There is no help desk configured at this address.
Ron HineRon Hine
I'm having the same issue with the display of the under constuction page. I've been through all the items mentioned in this thread a couple times. The one exception is the Anonymous Collection. I have it set to No. Can this cause this error? I've been testing with the survey and it appears that once I fill out a survey I can't change the Anonymous Collection option. Do I have to build a new survey to change this option?
Ron HineRon Hine
OK, I figured out how to get the Anonymous Collection turned on (just by turning off the collection option the Anonymous option was enabled). However, I'm still getting the under constuction page. I've been through all the permission settings and everything else looks OK. I'm using the following URL in my email template:{!Case.ContactId}&case_id={!Case.Id}&wf=yes

Is the below correct for the site set up?
Site set up
Jodi Nemser-AbrahamsJodi Nemser-Abrahams
I'm having the same issue as Tiffany and others.  Any further suggestions?!
Tiffany ChenTiffany Chen
what have you tried Jodi? Make sure to try the following:
- site configuration:
- create sharing rules on the object from which you are generating the survey
- make sure survey collect status is turned on
- make sure the link on the email template is the correct survey link
Jodi Nemser-AbrahamsJodi Nemser-Abrahams
Thanks, Tiffany!  I feel a bit silly about this, but I realized that I wasn't using the latest version of Timba when I ran into the difficulties.  Once I updated and ran through the public access settings again, everything worked!  

So far, I'm just trying a public url, so I might have more questions when I try an e-mail template.
I have tried sending the Timba survey link through a workflow for a custom object and it worked fine.

For Ex: Here my cusom object name is Participants: So the Survey id will be:

<a href="{!Participants__c.Id}&wf=yes">

In order to collect the survey, Anonymous Collection should be turned on under Timba Survey.

Try your luck!!!
Jodi Nemser-AbrahamsJodi Nemser-Abrahams
Does anyone know how to relate a survey to a campaign or account?  I think this explanation is missing a step or two:

These are the other threads I've found on this:
Jesse LingoJesse Lingo
So I have read through all posts.

I want to send a survey via workflow related to lead, but when I click the link I get page not found error message :(.

I've done:
  • Sites Config with public profile settings updated
  • Survey is active with settings updated for Log Enabled, Site Configured, sites url pasted
  • Collect and Anonymous Collect On
  • Updated email template and workflow with "custom"
  • All my settings are Public Read/Write
  • My Site is Active
Any ideas?
Julia TittermaryJulia Tittermary
I played with this for hours yesterday and the problem was SO SIMPLE. WHen on the collect tab you will see several on/off toggles. Make sure collection is set to on and that should solve the problem. 
Laura PaglioneLaura Paglione
@Tiffany Chen did you ever get this figured out? I also have done the following (borrowing from your earlier post):
  • Contact Sharing: Created Contact object sharing rule and Case object sharing rule based on this link:
  • Sites Configuration: Adjusted settings based on the Sites configuration link:
  • TimbaSurveys Deployment: Confirmed that the application is properly deployed based on this link:
  • Collections turned on: Made sure that the survey collect status is set to green, and that Timba Survey configuration has both “Log Enabled” and “Site Configured” checkboxes checked, with the Site URL being the Salesforce Site URL.
  • Email customization: Customize my email to be an HTML one as per the second half of
  • No Workflow: I am not using workflow; I'm sending to users directly through the Timba Survey's collection page.
  • TimbaSurveys version: I am using TimbaSurveys version 7.69; I'm using Salesforce Enterprise
  • SF Customer Portal: I DO NOT have customer portal set up. Salesforce has discontinued them with the summer '13 release (, and while we have the functionality, we never enabled them.
The result:
The URL the user is being directed to looks correct (I am using a custom URL and a path for the surveys):<confirmed SF ID for the contact>&id=<confirmed SF ID for the survey>

but, the page displayed is the "not enough access" message as show in the first note in this thread.

I'm about to give up and use a different tool. Did anyone have success?
Julia TittermaryJulia Tittermary

@laura paglione -

I had this problem and it ended up being a really simple fix when sending out the suvey. You have to make sure you check that they are allowed to answer. Its a simple toggle. Hope that solves it for you too!

Laura PaglioneLaura Paglione
@ Julia Tittermary thanks fir the response. What do you mean "allowed to answer the survey?" Do you mean turning the collector on? If so, I've done that already. In the collect tab for the survey collection is turned on. I have my fingers crossed that you mean somewhere else. Laura Paglione Technical Director, ORCID
Chris MorganChris Morgan
Hey y'all,

Has anyone run into the survey not associating with the Opportunity? I followed their setup for inviting from an Opportunity, but when we finish the survey it only attaches to the Contact. Additionally, when submitting the survey the first time we submit we get an unexpected error. Once we submit again the survey completes, but again it is only associated with the Contact record that was passed. This is the URL for the survey setup as described in the Timba How To section on their site.****0000006SIHDIA4&cId=****000000mwWuS&oppty=****000000D4z8X&wf=Yes

Thanks for any help.

Chris M
srinivasan thirumalaisrinivasan thirumalai
I could not get the survey to work. It is throwing an error: You are not allowed to fill this survey. it is not just for the community users, I am getting the error even if I login as the sys admin.
I did the following:
1. created a community.
2. configured necessary permissions for all the cases and the timbe survey related components to all the users.
3. Created the survey..
4. congigured the site in the survey and turned on the collections.

I don't see an  option to enable "Allowed to answer the survey". I am not sure if it has to enabled at the survey level or at the profile level. Any help is appreciated.
@Srinivasan, may I know how you are trying to take the survey. Is that survey linked to any object (case, opportunities...) or you are just pasting the survey link to the browser.
I just wanted to know, did you get the error even you tried to fill the survey for the first time? You may have to check the collection part of the survey.
User-added image
srinivasan thirumalaisrinivasan thirumalai
The collection is turned on my survey as well. The survey is linked to a Case and when the case is closed, an email will be sent containing the url to the survey. I am gettting the same error if I login as an external contact or even as an internal user.
User-added image 

The only I was able to do is: I could create a survey is through filling a survey on behalf of a contact or lead by clicking on the Phone icon.

User-added image
I had a trouble to send a survey once the case is closed through a workflow by using Timba Survey. So, I started using Survey Force and still its working wonderful. You may want to try the Survey Force.
Survey Force Link
Ron HineRon Hine
I struggled with Timba surveys and never could get it working. I couldn't get any help from their support. I wouldn't waste another minute on Timba. I don't know why they don't charge a little something for the app and provide decent support. 

I switched to GetFeedback. It works great. We were up and rolling with surveys in no time. This app automatically reformats for mobile devices too. I can launch a new survey in minutes. In a fraction of the time I spent trying to troublehsoot one Timba issue, I lunched an entire new survey program. Thier support is hyper responsive too. 
srinivasan thirumalaisrinivasan thirumalai
@Ron Hine and @Admin. Thank you very much for the guidance.
Laura PaglioneLaura Paglione
@Ron Hine - what a great recommendation to use GetFeedback. Great tool. Love its use of images within the survey. Also has a generous donation for nonprofits. I'll be making the switch from Timba today since I could never get it to work. Thanks!
Tawfik El-SarragTawfik El-Sarrag
@Tiffany Chen - did it work at all eventually?
Tawfik El-SarragTawfik El-Sarrag
hi everyone, does it work at all or this is a waste of time?
Dan LambDan Lamb
Most of the conversation for this was started 2 years ago and the links provided no longer work.  I am getting the exact same issue as everyone else, but am not able to see the instructions that were provided by links as those pages are not live anymore.  Does anyone have an update to this?

Terri FurgesonTerri Furgeson
Hi Dan,  Not sure if you have given up on this or not.    I've been working on it for a few days had all the the same issues as everyone else.   Followed all steps exactly and would get the error message.  I finally got it to work today!   

Under Set Up/Administration Setup/Sharing Settings 
Enable External Sharing Model

Once I did that I was able to test my workflow and have external users use the survey.   Hope this helps.    

User-added image