Users denied access to a specific report "Insufficient Privileges" - Answers - Salesforce Trailblazer Community
Trailblazer Community
Ask Search:
Doug BlanchardDoug Blanchard 

Users denied access to a specific report "Insufficient Privileges"

I have created a report and placed it in a folder accessible by our users. They are denied access to the report with the following message:

Insufficient Privileges
You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary.


All the other reports in the folder can be accessed by the users.

I am at a loss as to why they would be denied access to this specific report. Thanks for you help.
Steve MolisSteve Molis
 What object is the report being run on?  What are their permissions/sharing settings on that object? 
Doug BlanchardDoug Blanchard
The report is running on the Account object and a related custom object containing sales data. The permissions for Account are "Read,Create,Edit,Delete" and for the custom object "Read".

The Sharing Settings for Account are Private & Grant Access Using Hierarchies.
The Sharing Settings for the custom object are Controlled by Parent. Account is the parent object.
Steve MolisSteve Molis
 I think you may need to tweak your sharing settings, or schedule the report and select a Running User for the report who has read access to all of the data.
Sweta GaikwadSweta Gaikwad
I have a similar situation where the report is running off of 'Activity' and another custom object, where can I change the sharing settings??

Thanks

Steve MolisSteve Molis
@Sweta Gaikwad  which edition of SFDC are you using?
Laura MeerkatzLaura Meerkatz
 Check to see if the report is based on a custom report type. If it is, your report type status might still be "in development" instead of "deployed," which would mean most users wouldn't be able to access the report.
Christopher SweetChristopher Sweet
Thank you @Laura Meerkatz! I was at a loss. It would be cool if the report had a message on top that it was using an undeployed report type.
Leanne ArdleyLeanne Ardley
Oh my god, thank you so much @Laura Meerkatz! This was driving me crazy! I think SalesForce should warn you when creating a report that it is in this state. Or there should be some icon indicating this in the Reports tab. 
Parag SevraParag Sevra
FYI,

There are instances where you'll get an error message when you try to run a report that you should have access to. The reason behind this error could be due to a number of circumstances (Organization-Wide Defaults, Field-Level Security, Profile, and User permissions), all outlined below: 

Check the following: 
  •  First, check that your Report Type is in "Deployed" status. 
  • ​Even though you think you have access to the Report Folder, it's a good practice to double check that the access has not changed for some reason.
  • You don't have 'READ' access to one of the objects that the report references.​​
  • ​If the report is an Administrative report (reports on Users, Reports or Documents) you require the "View Setup and Configuration" permission on your profile.
  • Check the Field Level Security of the Lookup or Master-Detail Relationship field to ensure that your Profile has visibility to that field.  Without visibility into that specific field, you will not have the ability to view the relationship that it contains and thus not able to run the report.​
Note: You'll need to check the Field Level Security for every field that is on your report and in the object you are referring to.
  •  ​Profile permission "Report Builder" is not available on the affected User's Profile.
  • If the report is built on multiple objects, this error can occur if the Lookup Field between two of the Objects is hidden from you by Field Level Security.
  • If the Report Type used to create the report is 'Opportunities with Products,' and the affected user does not have at least 'Read' access to the Price Book object.
  • This same error may be encountered by users within Customer Portals/Communities and Partner Portals/Communities. This will occur if theOrganization Wide Default sharing for the Object(s) being reported upon is not set as Private. If further access should be granted to the remainder of your Organization, Sharing Rules can be defined. ​
Note: This error may also occur if the object used in a report type is part of a managed package that contains a visualforce page. Once an affected user tries to access a record, he will receive an error like the one below:
 
License Required: The Visualforce Page DeliveryGroupHome is part of the AppExchange Package KimbleOne, and requires a license to use."

Also check:
   

Regards,
Parag Harji Sevra
Brandon ChadwellBrandon Chadwell
@Sweta Gaikwad Thank you! I was just about to pose the same question and found this!
TPG PipelineTPG Pipeline
Great that I found this and now solved the problem!!
Ty FrancisTy Francis
For me it was the field-level security on the Lookup Field. Huge thanks @Parag!